Seller Advance Website Outage

Resolved

This incident has been resolved.
Posted May 20, 2021 - 22:42 BST

Investigating

We are observing a failure of the critical path on the Seller Advance Website
Posted May 20, 2021 - 22:39 BST